Excel-Felder mit „#WERT“ausblenden

Manchmal kommt es vor, dass in einer Excel-Zelle der Eintrag „#WERT“ steht, weil die Funktion die dieses Zelle beinhaltet nicht ausgeführt werden kann.

Um diesen Wert auszublenden verwendet man am besten eine Wenn()-Funktion in Verbindung mit der ISTFEHLER-Funktion:

=WENN(ISTFEHLER(Deine_Formel);"";Deine_Formel)

Somit wir das Ergebnis der Formel (Deine_Formel) nur dann angezeigt, wenn sie keinen Fehler ergibt; sont wird eben „“ (also nichts) angezeigt! ;)

3 Antworten auf „Excel-Felder mit „#WERT“ausblenden“

  1. Hallo,

    ich habe bereits eine längere Formel in der Zelle stehen.
    Dennoch wird der „#WERT!“ angezeigt.
    Hier habe ich die Formel…
    =WENN(ISTFEHLER(SVERWEIS(B17;’Ldm Tabelle‘!G5:J40;2;FALSCH));““;SVERWEIS(B17;’Ldm Tabelle‘!G5:J40;4;FALSCH))*H17

    1. Hallo Mario,
      du hast einen Fehler in deiner WENN-Funktion!

      Der grundsätzliche Aufbau der WENN-Funktion ist:
      =WENN(PRÜFUNG;WAS_WENN_WAHR; WAS_WENN_FALSCH)

      Wir kombinieren in dem o. g. Beispiel die WENN-Funktion mit der ISTFEHLER-Funktion; d.h. in der PRÜFUNG der WENN-Funktion steht (ermittelt durch die ISTFEHLER-Funktion) entweder ein WAHR (wenn ein Fehler vorliegt) oder ein FALSCH (wenn kein Fehler vorliegt). Dann geben wir in der WENN-Funktion an, dass bei WAHR (es liegt ein Fehler in der Formel vor) nichts angezeigt werden soll („“) bzw. bei FALSCH (es liegt kein Fehler vor) das gewünschte Formelergebnis angezeigt wird.

      Bei deiner Formel kommt nach der WENN-Funktion noch: *H17
      Daher wird dir auch ein Fehler angezeigt; dieser bezieht sich in diesem Fall nicht auf die „WENN/ISTFEHLER-Kombination“ sondern auf den Fehler in der WENN-Funktion.

      Du hast also:
      =WENN(PRÜFUNG;WAS_WENN_WAHR; WAS_WENN_FALSCH)*H17
      … und genau das funktioniert nicht. 😉

      1. DANKE für die schnelle Rückmeldung …. ich muss noch folgendes hinzufügen:
        Wenn in der besagten Zelle drin steht, zeigt es mir den #WERT! an.
        Wenn ich meine Zelle mit den Daten fülle, habe ich bei der Zelle wo #WERT! drin steht, mein Ergebnis drin steht.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.