EXCH2010: Mailzustellung nicht möglich (SMTP 554 5.1.0 Sender denied)

Hallo allerseits,

heute habe ich ein ganz kurioses Problem 😕

Wir verwenden den Exchange 2010 auf einem Windows Small Business 2011.
Hier holen wir mit dem Windows SBS-POP3-Connector die Mails vom Provider (STRATO) ab und stellen sie dem Exchange-Server per SMTP zu.

Problem:

Ich erhalte im 5-Minuten-Takt Fehlermeldungen in der Ereignisanzeige des Servers, die sich immer nur auf ein Exchange-Postfach beziehen:

Im POP3-Log sieht das dann wie folgt aus:

[t 0] 05/22/17, 07:37:40: Sending message 3 to the SMTP recipient empfänger@domäne.de
[t 0] 05/22/17, 07:37:40: (SMTP) [TX] MAIL FROM: <sender@spamdomäne.de> RET=FULL
[t 0] 05/22/17, 07:37:40: (SMTP) [RX] 250 2.1.0 Sender OK
[t 0] 05/22/17, 07:37:40: (SMTP) [TX] RCPT TO: <empfänger@domäne.de> NOTIFY=FAILURE
[t 0] 05/22/17, 07:37:40: (SMTP) [RX] 250 2.1.5 Recipient OK
[t 0] 05/22/17, 07:37:40: (SMTP) [TX] DATA
[t 0] 05/22/17, 07:37:40: (SMTP) [RX] 354 Start mail input; end with <CRLF>.<CRLF>
[t 0] 05/22/17, 07:37:40: (SMTP) [TX]  .
[t 0] 05/22/17, 07:37:45: (SMTP) [RX] 554 5.1.0 Sender denied

Erklärung:

Die Erklärung ist eigentlich sehr einleuchtend und logisch, wenn man es erst mal verstanden hat  😀
Der Benutzer, dem das betroffene Postfach gehört, hat in Outlook für eine bestimmte Adresse festgelegt, dass es sich hierbei um Spam handelt und die Mails von dieser Adresse abgelehnt werden sollen:

Jetzt kommt von genau dieser Adresse eine Mail.
Der  POP3-Connector holt sie vom Provider (STRATO) ab und möchte diese Mail dann an den Exchange-Server (SMTP) übergeben, kann das aber nicht, denn dieser hat ja die Info, dass er Mails von dieser Adresse nicht annehmen soll.

Und somit „hängt die Mail zwischen den Diensten fest“, und kann nicht zugestellt werden.

Lösung:

Die Lösung ist eigentlich ganz einfach … wir deaktivieren den Spamfilter, die Mail wird zugestellt und der „Fehler“ ist behoben.
Anschließend sollte man den JunkMail-Eintrag des Benutzers löschen und den Spamfilter wieder aktivieren.

In der Exchange Powershell gibt man folgende Befehle ein:

1. Kontrollieren ob der Filter aktiviert ist:
Get-SenderFilterConfig | Format-List Enabled

Enabled : True (bedeutet, dass der Filter aktiv ist)

2. Deaktivieren des Filters:
Set-SenderFilterConfig -Enabled $false
3. Mails abholen

Wir starten die Windows Small Business Server 2011 Konsole und starten unter Netzwerk > Konnektivität > POP3-Connector > Zeitplanung > Jetzt abrufen den Abholvorgang:

Die Meldung „Die POP3-E-Mail wurde erfolgreich abgerufen“ zeigt uns, dass jetzt alles korrekt abgeholt und zugestellt wurde.

4. Spamfilter wieder aktivieren

Jetzt starten wir in der Exchange Powershell den Spamfilter mit dem Befehl:

Set-SenderFilterConfig -Enabled $true

Anschließend sollte der betroffene Benutzer seinen JunkMail-Filter wieder löschen, denn bei der nächsten Email von dieser Adresse würde das selbe Problem erneut auftreten!

TIPP: Verwenden Sie die Spam-Filter-Funktion Ihrer Antiviren-Software! 😉

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.